JRuby 1.5.6 (I know. Old) Rails 3.0.1 Polyglot 0.3.3 UPDATE: see easier fix below Getting the following error when bundling: {% highlight ruby %} Java::JavaLang::ArrayIndexOutOfBoundsException: An error occured while installing polyglot (0.3.3), and Bundler cannot continue. Make sure that gem install polyglot -v '0.3.3' succeeds before bundling. {% endhighlight %} JRuby YAML parser is erring with this version of Polyglot (don’t you love JRuby!!). ‘gem dependency -R polyglot’ will get you the reverse dependencies on the library. In this case it’s ‘treetop’ Had to edit the ‘gemspec’ files and restrict the version of polyglot to ‘< 0.3.3’ Example - From s.add_runtime_dependency(%q, [">= 0"]) To s.add_runtime_dependency(%q, [">= 0", "< 0.3.3"])

Yak shaving!!!

UPDATE: EASIER FIX: just use gem 'polyglot', '0.3.2' in your Gemfile, it might just do the trick. </polyglot></polyglot>