Skip to content

JRuby and Polyglot

JRuby 1.5.6 (I know. Old)
Rails 3.0.1
Polyglot 0.3.3

UPDATE: see easier fix below

Getting the following error when bundling:

JRuby YAML parser is erring with this version of Polyglot (don’t you love JRuby!!).

‘gem dependency -R polyglot’ will get you the reverse dependencies on the library. In this case it’s ‘treetop’

Had to edit the ‘gemspec’ files and restrict the version of polyglot to ‘< 0.3.3' Example - From s.add_runtime_dependency(%q , [“>= 0″])
s.add_runtime_dependency(%q , [“>= 0″, “< 0.3.3"]) Yak shaving!!! UPDATE: EASIER FIX: just use gem ‘polyglot’, ‘0.3.2’ in your Gemfile, it might just do the trick.

Posted in Ruby.

0 Responses

Stay in touch with the conversation, subscribe to the RSS feed for comments on this post.

Some HTML is OK

or, reply to this post via trackback.